Hey! I see you! Please take two seconds to sign up! We'd love to have you as a member of our Kia Stinger club. You have nothing to lose and so much to gain... :)

SA352 - ECU Replacement

Discussion in 'Kia Stinger TSB Discussion' started by TwiceStung, Nov 25, 2018.

  1. Guest-113404

    Guest-113404 Guest

    I have - slightly over 1mpg since the replacement!
     
  2. Tri-Cities Owner

    Tri-Cities Owner United States Newish Member

    8
    10
    3
    I have - about 1 mpg!
     
  3. SOCAL2.0

    SOCAL2.0 United States Member

    99
    17
    8
    My stinger had no symptoms had ECU replaced and got no noticeable improvements Oh well!
     
  4. rocket23

    rocket23 United States 1000 Posts Club!

    1,276
    201
    63
    Location:
    Ct.
    wifey was a passenger the other day....she asked why does the car lurch forward?!....I said what part of ''sport sedan'' don't you understand.......
     
    • Funny Funny x 1
  5. G-606058

    G-606058 Guest

    Also had my ECU replacement on my 2.0 Stinger today because they said it needs done but failed to explain why
     
  6. rocket23

    rocket23 United States 1000 Posts Club!

    1,276
    201
    63
    Location:
    Ct.
    My car incidentally had the hesitation problem ,with the previous owner,but they blamed the fuel rail......could very well have been the ecu.......and a trans logic....could of been the ecu......2 turbos.......again could of been the ecu.....the ecu is the ''brains'' of the whole car if it's defective like the ''abby normal '' brain in ''young frankenstein , the movie.....then it needs replaced.
     
    • Like Like x 1
  7. Alagos

    Alagos Germany Active Member

    182
    48
    28
    Location:
    Germany / Hannover
    Im not sure if it’s the same thing .. having my car for 10 months now, had an oilchange and I’m at 12900km now.

    when turning on it sometimes wont get fuel .. so it’s stuttering a bit at the beginning. Then it shakes through the whole car. 2 times in 2 weeks now my consumption on 2 days only for the same way went up from 7-8l/100km to 11-12l/100km ... today I got it back after replacing the fuel pump .. had the problem again on my way home ..

    It behaves that the consumption is over 10 liters on a linear highway with even holding 60 km/h ..

    Is that the same or another unknown issue ?
     
Draft saved Draft deleted

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.