kia stinger store

What is needed, what is suggested for JB4?

TimT

Active Member
155
102
43
Hi

So i've been trying to research JB4 and fully understand what is NEEDED and what is SUGGESTED when running beyond map 1, for example for map 2. I've seen people change their intercoolers, intakes etc but are they all NEEDED if I want to stick to map 2 for daily driving? Or is a set of changed spark plugs, gapped properly, good enough? What is the realistic horsepower jump for a JB4 with spark plugs running map 2?
Is there also a noticeable performance boost for map 2 if in addition to spark plugs, other things such as intakes / intercooler are changed or is it just a long term reliability boost for the car?

I have a feeling that some (if not most) of these questions are something that most people looking at JB4 run into so I figured I might aswell make it into a topic.

//for gasoline reference regarding potential boost, I use 98 octane fulltime, Europe does not have below 95 (Which has bioadditives due to emission regulations so like equilavent of 91 in US)
 
Last edited:

Terry@BMS

Authorized Vendor
2,962
1,693
118
Nothing is needed, the maps are based more on fuel used than anything else. 98 RON is like 93 RM2 in the USA so you should be fine with map2. For all maps you will benefit with an intake like the BMS intake. ;)

Plugs are suggested for any tune or map as the factory gaps are a big issue. You can just regap the factory plugs down to 0.022" if you want or replace them all together.
 

TimT

Active Member
155
102
43
So essentially map 2 could be fine to use with just a spark plug change and extra work reliability would be from intakes? What is the difference between changing the gap on plugs and changing them all together? Denso ones (or something amongst that) are just better for performance and long-term reliability compared to OEM?
______________________________
 

Terry@BMS

Authorized Vendor
2,962
1,693
118
The DENSO plugs work a little better at higher boost levels and are inexpensive at $60 for the set. My opinion is since it's a PITA to swap plugs, might as well replace them at the same time IMHO.

Map2 is fine for a factory car with plugs, with or without an intake.
 

VicV8

Newish Member
17
7
3
Nothing is needed, the maps are based more on fuel used than anything else. 98 RON is like 93 RM2 in the USA so you should be fine with map2. For all maps you will benefit with an intake like the BMS intake. ;)

Plugs are suggested for any tune or map as the factory gaps are a big issue. You can just regap the factory plugs down to 0.022" if you want or replace them all together.
Had my JB4 and Denso plugs installed and within 24 hours have a check engine light and JB4 app is giving code 0113. Any insight? Car started to run really rough and jerky and would no longer go so I luckily made it to a gas station. Car still turns on but shuts down after a minute or with a jerky start. Towed to the shop and will have them uninstall and hopfelly the problem can be fixed.
 

turboAWD

Sustaining Member
1,415
336
88
West Coast
Had my JB4 and Denso plugs installed and within 24 hours have a check engine light and JB4 app is giving code 0113. Any insight? Car started to run really rough and jerky and would no longer go so I luckily made it to a gas station. Car still turns on but shuts down after a minute or with a jerky start. Towed to the shop and will have them uninstall and hopfelly the problem can be fixed.
0113 is "intake ambient temperature high condition" fault. I.e. the intake air sensor is reading continuously high (possibly open circuit). Did you not plug one of the wires/plugs correctly, or did it come undone?

Step 1 - unplug all jb4 stuff and see if it works ok then. Check all your other plugs too.
 

basysmith

Active Member
176
76
28
Melbourne
I run Map 3 as daily on 98 which is your 93 with intakes, Varex and few other mods.
 

VicV8

Newish Member
17
7
3
0113 is "intake ambient temperature high condition" fault. I.e. the intake air sensor is reading continuously high (possibly open circuit). Did you not plug one of the wires/plugs correctly, or did it come undone?

Step 1 - unplug all jb4 stuff and see if it works ok then. Check all your other plugs too.
The plug either came loose and was not plugged in properly. Everything seems to be running fine now but scared the hell out of me lol.
 
Top