kia stinger store

Jerky Cruise Control?

Kamauxx

2500 Posts Club!
4,784
1,978
118
Anyone else notice the car jerking/lurching when cruise is enabled?

I first noticed it on my drive home from the dealership a couple of months ago but I shrugged it off. I don't use cruise a whole bunch so it wasn't a huge deal until yesterday when it drove me mad on a 350 mile trip I took.

It feels like the computer is having a hard time making fine adjustments to the throttle bottle.
 

bugaboo90

Active Member
193
108
43
I use cruise often and haven't noticed the issue. The only issue I've had is around the recognizing the car in front, but it's something I just have to get used to coming from a subaru's eyesight system.
 

Kamauxx

2500 Posts Club!
4,784
1,978
118
I use cruise often and haven't noticed the issue. The only issue I've had is around the recognizing the car in front, but it's something I just have to get used to coming from a subaru's eyesight system.

I'm hoping this is something that can be fixed in my garage. Maybe a dirty throttle body...I really don't want to bring it to my local dealer. It's a really trashy looking joint Kia/Mazda service center. I don't have a lot of confidence in their abilities to diagnose and repair a problem on a brand new platform.

Interestingly while searching Google for a remedy I found a post on an Acura forum from 2015, made by our very own @Mike_TX (small world!). He had a similar issue with his Acura but I don't see a follow-up post from him.

Mike, we're you ever able to find a cure for the problem? Faulty APP sensor?
______________________________
 

bugaboo90

Active Member
193
108
43
so does it happen all the time? randomly? doesit go along fine fir a while then all of the sudden it does it? have you noticed the car icon active during the issue time?

For me the most only lerching that I guess I have is when to falsely thinks there is a car in front of me as I am on a downgrade or going around a curve. It thinks there is a car so it slows down or hits the brakes hard and then all of the sudden the condition changes and it accelerates.

Net, keep track of the car icon to see if it thinks there is a car in front.
 

Mike_TX

Stinger Enthusiast
550
257
68
North Texas
I'm hoping this is something that can be fixed in my garage. Maybe a dirty throttle body...I really don't want to bring it to my local dealer. It's a really trashy looking joint Kia/Mazda service center. I don't have a lot of confidence in their abilities to diagnose and repair a problem on a brand new platform.

Interestingly while searching Google for a remedy I found a post on an Acura forum from 2015, made by our very own @Mike_TX (small world!). He had a similar issue with his Acura but I don't see a follow-up post from him.

Mike, we're you ever able to find a cure for the problem? Faulty APP sensor?

Hi,Kamauxx. This thread brought up old memories!

Sadly, I did not ever find a solution, in spite of efforts by the dealer and consultations with other dealers. One dealer even hooked a laptop up to the car and went riding with me, but they still couldn't figure out what was causing the "lurch". I use cruise all the time, and it was annoying enough to me that I traded the car.

I'd describe it as almost like there was slack in the throttle, or a momentary delay in lockup/unlocking of the torque converter. The result was a repetitive ping-pong, on/off effect, especially when going down a grade. Whether it was in the throttle control or the transmission I never found out.

Hope it gets sorted out.
 

Kamauxx

2500 Posts Club!
4,784
1,978
118
so does it happen all the time? randomly? doesit go along fine fir a while then all of the sudden it does it? have you noticed the car icon active during the issue time?

It happens all the time ONLY if I'm using cruise control. As soon as I disable it the car drives smooth as can be. I'd say I feel a jerk every 10-15 seconds. But this is on a GT1 so it's not an adaptive cruise issue.
 

Kamauxx

2500 Posts Club!
4,784
1,978
118
Hi,Kamauxx. This thread brought up old memories!

Sadly, I did not ever find a solution, in spite of efforts by the dealer and consultations with other dealers. One dealer even hooked a laptop up to the car and went riding with me, but they still couldn't figure out what was causing the "lurch". I use cruise all the time, and it was annoying enough to me that I traded the car.

I'd describe it as almost like there was slack in the throttle, or a momentary delay in lockup/unlocking of the torque converter. The result was a repetitive ping-pong, on/off effect, especially when going down a grade. Whether it was in the throttle control or the transmission I never found out.

Hope it gets sorted out.

Thanks for responding, Mike. Sucks that they didn't get it figured out. I guess I'll have to take some time off work and bring the car to a service department a little farther south.
______________________________
 
I have this experience, as well, although I wouldn't necessarily call it "jerky"... I would call it, "surge-y", if that makes sense. Like a recurring light roll-on, roll-off of the throttle when CC is on. Seems like it occurs most often/is most noticeable when the road is mostly flat.

Perhaps this is a side effect of the radar-based system's implementation in our cars? Unsure myself.
 

Kamauxx

2500 Posts Club!
4,784
1,978
118
Sounds like we have the same problem.

I don't have adaptive cruise control so I doubt it's a problem with the radar.

Has your car done it since new?
 

Kamauxx

2500 Posts Club!
4,784
1,978
118
So, I'm doing some research on this now...

Looks like an issue on the current-gen V6 Sorento, as well.

Cruise control "surging" - Kia Forum

I have a 30 mile drive coming up in a bit. I'll see what kind of testing I can accomplish.

Yep, quite a few of them have described exactly what I'm talking about.

It sucks rhat they never found a solution. At least that one guy on the last page got some money to live with it.
______________________________
 

jrhodes87

Active Member
321
189
43
yep I noticed this on my cruise control as well. But I never use cruise control so it's not a huge issue for me. but yes I did notice this exact thing
 

Mike_TX

Stinger Enthusiast
550
257
68
North Texas
I just got back from a 2500-mile trip in my 2017 Optima SX-L, and the cruise worked flawlessly. I don't understand why they have something that works well, then they change it for a different model.
 

Kamauxx

2500 Posts Club!
4,784
1,978
118
I just got back from a 2500-mile trip in my 2017 Optima SX-L, and the cruise worked flawlessly. I don't understand why they have something that works well, then they change it for a different model.

Yea I never had any issues with the CC on my SXL either. I'm hoping it's a simple software fix that they'll end up developing or that the ECU will "learn" itself out of surging.
 

Kazz

Texas Stinger Swarm
STL Stinger Club
1,586
553
118
Illinois
I over-use my cruise, I'm sure. And since day one I noticed there was some surging to the cruise control. I've had passengers in the car when I noticed it but nobody made any comment. Of course, what do they know if I'm in cruise or not.

I *THINK* it's more prevalent in Comfort & Eco than Sport. But I've felt it in Sport some.

I also think that this is probably only noticeable to those of us who pay a lot of attention to how the car is operating/handling at all times. I'm a bit of a fanatic like that. LOL

All that said, I'm not worried about it. I assume they'll have a fix for it.
 
Top